1.10.08

Y se rompió.

zangre@zangre-linux:~$ su root
Contraseña:
root@zangre-linux:/home/zangre# apt-get install postgresql
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.

Como sólo solicito una única operación, es extremadamente posible que el
paquete simplemente no sea instalable y debería de rellenar un informe de
error contra ese paquete.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
postgresql: Depende: postgresql-8.3 pero no va a instalarse
E: Paquetes rotos

OPCION A: paso de instalar.
OPCION B: formateo.
OPCION C: ¿sugerencias?

Ya tardaba demasiado en rompé linuz.

12.45h: me sugieren cositas:
zangre@zangre-linux:~$ SU
bash: SU: orden no encontrada
zangre@zangre-linux:~$ su
Contraseña:
root@zangre-linux:/home/zangre# apt-get install postgresql-8.3
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.

Como sólo solicito una única operación, es extremadamente posible que el
paquete simplemente no sea instalable y debería de rellenar un informe de
error contra ese paquete.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
postgresql-8.3: Depende: libldap2 (>= 2.1.17-1) pero no es instalable
E: Paquetes rotos
root@zangre-linux:/home/zangre# apt-get install libldap2
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
El paquete libldap2 no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente
Sin embargo, los siguientes paquetes lo reemplazan:
slapd libldap-2.4-2
E: El paquete libldap2 no tiene candidato para su instalación
Esto va de mal en peor. xD

13.09h aptitude update (al hacer el apt-get install postgresql vuelve a dar el mismo error).
13.10h aptitude install libldap-2.4-2 (al hacer el apt-get inicial mismo error).

Recordad: Morded o Seréis Mordidos

    # Escuchando...  Paradise Lost; Erased.

2 mordiscos:

darkomen dijo...

no uses apt-get!! usa aptitude siempre que es mucho mejor con el tema de dependencias y demás.. a partir de ahora usa ese siempre!!
un saludo

Jean Bedel dijo...

Esto con Windows no te hubiera pasado. Peazo friki!

  

  

Visitas desde octubre 2002: (Estadisticas)